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Welcome
Welcome to Bartleby, an app to quickly publish ebooks from your Mac or iPad. This manual is your guide to using Bartleby.

Bartleby works differently than other writing tools, such as word processors. Instead of worrying about details like fonts, margins, and spacing, mark the parts of your book that aren’t body text, such as chapter titles and section headings. Bartleby handles the rest, generating an ebook for you.

Questions
If you have any questions about Bartleby or this manual, go to the Bartleby site and click the Send Feedback button.

Working with Books
The heart of a book publishing program is books. In this chapter you will learn how to work with books.

Creating Books
When you launch Bartleby on Mac, a new book should be created for you. If you see no book, choose File > New or press Cmd-N to create a new book.

On iPad a document browser opens when you launch Swift Book Builder. Tap the Create Document icon to create a new book.

The Book Window
When you create a book a window will open for the book.
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The book window has the following sections:


	Toolbar

	Chapter list

	Chapter view

	Image browser



The toolbar has buttons for common commands.

The chapter list has a list of chapters in the book. In Bartleby anything that is its own unit is a chapter. In addition to chapters, Bartleby treats units like a copyright page and a dedication page as chapters.

Select a chapter from the chapter list to see its contents in the chapter view. The main part of the chapter view is the text view.

Below the text view are two menus. The first menu is for adding tags to mark things like section headings and bold text. The second menu is for choosing a theme that controls how the text in the text view looks.

The image browser shows the images that are in the book. It will be empty when you create a new book. Currently only the Mac version has an image browser. The Images chapter goes into more detail on the image browser.

Setting a Book’s Title and Author
Click or tap the Metadata button in the toolbar. A sheet opens.
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Enter the book title in the Title text field. Enter the author in the text field. Use the Identifier text field to enter an ISBN number or some other unique identifier for the book. Click or tap the Done button to finish setting the title and author.

Adding a Book Cover
Click or tap the Metadata button in the toolbar. Click or tap the Choose Cover button to select an image file to use as your book cover. Click or tap the Done button to finish adding the book cover.

Saving Books
On Mac choose File > Save to save your book. The first time you save, Bartleby will prompt you to choose a name and location for the book file.

Bartleby supports autosaving so you don’t have to constantly save your book manually.

The iPad version does not prompt you to save. Creating the book performs the initial save. After creating the book the iPad version autosaves the book.

Reverting to an Earlier Version of Your Book
Bartleby supports macOS’s document versioning system that lets you browse all the saved versions of your book so you can go back to an earlier version. Choose File > Revert To > Browse All Versions to browse the versions of your book.

The iPad version does not support reverting to an earlier version of your book.

Previewing a Book
Click or tap the Preview button in the toolbar to preview your book, or choose Book > Preview on Mac.

[image: Preview Window]

Select a chapter from the chapter list to preview its contents.

Publishing a Book
Click or tap the Publish button in the toolbar to publish your book, or choose Book > Publish on Mac. Choose a location to save the EPUB book and click or tap the Publish button. It may take a while to publish a long book.

Exporting a Book
If you want to get your book's data out of Bartleby, export the book.

Choose Book > Export on Mac or tap the Export toolbar button on iOS to export the book.

Currently Bartleby exports only to Markdown.

Importing Scrivener Projects
Bartleby can import Scrivener projects. You must perform the following steps to import a Scrivener project:


	In Scrivener compile the project to MultiMarkdown.

	Create a new book document in Bartleby.

	Import the MultiMarkdown book in Bartleby.

	Import the images from the Scrivener book in Bartleby.

	Fix the Markdown for the images.



Compile the Scrivener Project to MultiMarkdown
Open your Scrivener project. Choose File > Compile. Scrivener's Compile sheet opens.
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Choose MultiMarkdown from the Compile to menu at the top of the sheet. MultiMarkdown is the format that works best with Bartleby.

Choose the Default item from the Formats list on the left side of the sheet.

The Compile sheet should select all the text files in your book in the list on the right side of the sheet. Make sure every section you want to import has its checkbox selected.

Click the Compile button to compile the book. A Save panel opens for you to choose a location to save the compiled book. Click the Export button to compile the book.

Scrivener creates a folder at the location you chose. There should be one text file that contains the book's text and one file for each image in the book.

Create a New Book Document
When importing an entire book, Bartleby deletes any empty chapters before doing the import. Create a new book document by choosing File > New on Mac and use that book to import your Scrivener project.

Import the Book to Bartleby
After compiling your Scrivener project, you can import it to Bartleby.

Click the Import button in the toolbar or choose Book > Import to import the book. An Open panel opens. Select the text file and click the Open button.

Bartleby creates a chapter title for each Heading 1 item it finds in the MultiMarkdown book.

Import Images
Currently Bartleby does not automatically add the Scrivener book's images to the image browser. But you can import all the book images to Bartleby with one button click.

Click the Import button in the image browser on the right side of the window. Select the image files in the Scrivener book's folder and click the Open button.

Fixing the Image Markup
There is a quirk in the Markdown that Scrivener's compiler generates. Scrivener's generates Markdown for images that looks like the following:

![An image file][ImageFile]


The correct Markdown places the image file in parentheses, not square brackets.

![An image file](ImageFile.png)


You must also add the file extension, .png in the example, for each file for the image files to appear in the published book.

Working with Chapters
Books are made up of chapters. Select a chapter from the chapter list to view and edit its contents in the chapter view.

Empty Chapters Are OK
Bartleby ignores empty chapters when publishing a book so you can leave empty chapters in the chapter list.

Adding a Chapter
Select a chapter from the chapter list and click or tap the Add button below the list. A sheet opens.
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Enter the chapter title in the text field and click or tap the Add Chapter button. On Mac the new chapter appears below the chapter you selected in the chapter list. On iPad the new chapter appears at the end of the chapter list.

Renaming a Chapter
On Mac select a chapter from the chapter list. Press the Return key. Type the new chapter name.

On iPad tap the Edit button at the top of the chapter list. Tap on the chapter you want to rename. Type the new chapter name. Tap the Done button when you're finished.

Reordering Chapters
On Mac select the chapter you want to move and drag it to where you want it in the chapter list.

On iPad tap the Edit button at the top of the chapter list. On the right side of each chapter is an icon with three horizontal lines. Tap and hold the icon to select the chapter. Drag the chapter to where you want it in the chapter list. Tap the Done button when you're finished.

Removing a Chapter
On Mac select a chapter from the chapter list and press the Delete key.

If you accidentally remove a chapter, choose Edit > Undo to restore the chapter.

On iPad tap the Edit button at the top of the chapter list. Tap the Delete button next to the chapter you want to remove. Tap the Done button when you are finished.

Tags
Bartleby uses tags to designate parts of your book as things like section headings, links, and blockquotes. In this chapter you’ll learn how to work with tags in your books.

You Don’t Need to Tag Paragraphs
Anything you don’t explicitly tag is a paragraph. If you’re publishing a novel, you won’t have to tag much.

Tagging Text
Select the text you want to tag and choose a tag from the Tags menu.

When you tag text, Bartleby adds the markup for the tag to the selected text. The most common tag characters are asterisks, hashtags, and backticks. If you mistakenly add a tag, remove the markup text in the text view.

Images
Not every book needs images, but if your book has images, read this chapter.

Working with Images on iOS
To add images to books on iOS, you must move the images to the Bartleby app's Documents folder. Use the Files app to move the images.

The Image Browser
The image browser is where you work with images in Bartleby.
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At the top of the image browser is a list of the images in the book. Selecting an image shows the image below the list along with the file name of the selected image.

The image browser is on the right side of the window in the Mac version. Tap the Images button in the toolbar to open the image browser on iOS. The iOS version also has a Done button to close the image browser sheet.

Adding New Images to a Book
A new book has no images so start by adding images to the book browser.


	Click or tap the Import button.

	Select the images you want to add.

	Click the Open button on Mac or tap the Done button on iOS.



Inserting Existing Images
If you want to use the same image in multiple places in your book, use the Insert button.


	Select the chapter where you want to insert the image.

	Click or tap on the location in the chapter text where the image should go.

	If you have alt text for the image, select it in the text view.

	Select the image from the list in the image browser.

	Click or tap the Insert button.

	Tap the Done button on iOS.



The inserted image should look similar to the following in the chapter text:

![](ImageName.png)


To add alt text to the image for people with impaired vision, add the alt text inside the square brackets.

![Image Description(ImageName.png)


Selecting text in the text view before clicking the Insert button will convert the selected text to alt text for the image.

Deleting Images
Select an image from the image list and click or tap the Delete button to remove the image from the book.

Any references to the image in the book text will not be deleted. You must go through the book text and manually remove any references to the deleted image.

Markdown Introduction
Bartleby uses Markdown to mark text as section headings, italics, and links. Markdown is a popular markup language for writing on the Web. When you add a tag to your text from the Tags menu, you are adding Markdown tags to the text.

If you learn a little Markdown, you can tag text more efficiently.  Using Markdown also lets you use tags that aren't in the Tags menu.  In this chapter you'll learn about the most common Markdown tags.

Paragraphs
Most Markdown text consists of paragraphs or body text. Plain text without any markup is a paragraph.

This is the start of a paragraph.


Italics
Put an asterisk at the start and end of the text you want to italicize to make the text italic in the published book.

His favorite novel was *The Great Gatsby*.


Bold
Put two asterisks at the start of a block of text to make the text bold in the published book.

Do **not** put your hand on a hot stove.


Section Headings
Start a line of text with one or more hashtag characters and a space to mark the text as a section heading. Use one hashtag character for Heading 1, two characters for Heading 2 and so on.

# Section Heading Level 1
## Section Heading Level 2
### Section Heading Level 3
#### Section Heading Level 4
##### Section Heading Level 5
###### Section Heading Level 6


Lists
Put an asterisk and a space before the text to mark the text as an unordered list item.

Social Media Platforms

* Facebook
* Instagram
* Twitter/X


Put a number and a dot before the text to mark the text as an ordered list item.

1. First step
2. Second step
3. Third step


Lists are the area where you can speed things up the most by using Markdown.

Blockquotes
Put a right angle bracket and a space to mark the text as a block quote.

> The only thing we have to fear is fear itself.


Computer Code
Markdown has a couple of tags that will help people writing books about computer programming. The first is inline code, which usually involves the names of variables and data structures in a paragraph. Put the backpack character at the start and end of the code text.

`NSObject` is the base class for most of the classes in the UIKit framework.


The second is code blocks, which are used to show source code listings. Put three back ticks on a line before the start of the code block and at the end of the code block.

```
mutating func read(data: Data) {
	if let stringData = String(data: data, encoding: .utf8) {
		contents = stringData
	}
}
```


Links
Markdown links have two parts. The first part is the link text, which appears in square brackets. The second part is the link destination.

[Bartleby site](https://www.checksimsoftware.com/bartleby)
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